ハンダブリッジ発見しました

取り急ぎ原因の一つと思われるハンダブリッジがありました。

ヒントを探るべくWEB検索をしていたら、group.ioで似たような症状がある方のディスカッションボードを見つけたので読んでいました。

https://groups.io/g/ucx/message/2534

ここに「念の為、Jack端子がショートしていないかもう一度見て」というのがあったので、これをヒントに自分もテスターを当ててみました。

すると、MIC/PTT(CON2)のうち2つの端子がGNDに接続していたので、SMDのCON3も調べたらやはり2端子がGNDへ。Con3(2)とCon2(2)は接続しているのですが、回路図で見るとこれはATmega328Pの18ピンに繋がっておりGNDへは落ちていません。

よく見たら3番端子とGNDに半田ブリッジがあり、これがPTTを閉じた状態を作っていました。

汗顔の至です^^; ^^; ^^;

反省点

このジャックがSMDであることを深く考えず、ジャック類を最後にはんだ付けした際にようやく隣の抵抗R21が邪魔になることに気がつきました。

しかし何とかなるかと、その場凌ぎでハンダ付けしてブリッジしました。

ひどいことに、このジャックは4ピンなのにその認識なく3ピンと思い込んでいて、それをブリッジと見ていなかったことです。

SJ43514SMT取り外し失敗

というわけでブリッジしたハンダを吸い取り線で採ったものの相変わらず通電しているので吸い取り線をしつこく当てていたら、端子が融けて外れてしまいました。ブリッジはなくなりました^^;

それで、改めて電源を入れ直してみると、RとTとが入れ替わっている問題はなくなりました。またメニュの反応は悪いものの切り替えができるようになりました。エンコーダの回転方向が逆向きなのは相変わらず。

新たな問題

起動時に「!!V3.3=5.0V」というメッセージが2秒程度出ます。

あまり気にしていなかったのですが、こちらによるとSCLにかかるべき電圧は3.3Vであるべきだけど5.0Vになっているというエラーのようです。

ソースを見ると、SCL電圧を参照して基準値から外れるとこのメッセージを出すようです。

SI5351モジュールの電圧を測ると、Vccは4.9VでSCLも4.9Vを示しています。ICを直付する場合はダイオードと抵抗で電圧を調整しているようですが、モジュールではレギュレータがその役割を担っているようで、レギュレータの電圧を測るとVcc4.9V、Out3.3Vで正常でした。SCLと接続しているのはATmega328でその間には何もなく、つまり触りようがありません。

この場合、SCLの4.9Vはモジュール基板内部でVccと短絡しているか、チップ自体の不良以外の可能性はなかなか考えにくいです。

5351モジュールは一発勝負ではなく、いくつか購入した中から当たりを見つけるというレベルのものなのでしょうか?

う〜む、一難去ってもう一難。自作は楽しい^^;

Last updated 2024-05-17

Call Sign/QRA: コメント:

JG1SNX | JCC#1030 | GL: PM95SR | jg1snx(あま)jarl.com

いまさらハム

ようこそ(←初めての方へのご挨拶)

40の手習いで三アマ、還暦前に一アマ取得。小型船舶と共に海特3。

いわゆるアパマン(しかも1F)で環境劣悪のため専ら自転車で移動し公園などでの運用スタイル。

夢は武蔵・多摩の丘から自作機で移動運用すること。

ハンディ機と特小を持って自転車で動ける範囲でお手軽運用。

今日もチャリン歩deハム!

コールサイン

移動運用日誌

<< 2024-6 >>
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30

あれこれ研究室

学んだり試したりしたこと

サイト検索

キーワード

更新履歴

2024/6/23

2024/6/20

2024/6/18

2024/6/17

2024/6/16

2024/6/15

2024/6/13

管理者ページ